# Void

# Yeah but why?

Every time you create a null you are actually creating a solid layer that has to live in a Solids folder in the Ae project. Every time you import a project into another project this Solids folder comes with it, and if you import that project into another project you have 2 Solids folders, but in different locations unless you manually manage the project (which you wont do). You see where this is going.

And don't get me started on the top-left anchor point. πŸ™„

Void layers are shape layers that do not exist in the project panel and make for a lighter project. They are truly empty. Stare into the void.

# Download

Pay what you want

# Controls

The interface is split into 2 areas, Create and Replace.

Void controls

# Create

These top 3 buttons are used to create the shape layer alternatives to Null, Solid and Adjustment layers.

# New Void

Click to create a shape layer alternative to a Null layer. Any selected layers will automatically be parented to the new Void layer

Void controls

Select a single layer and the new Void will be created at the anchor point of the selected layer. This will zero out the Position, Scale and Rotation of the selection.

Void controls

Select multiple layers and the new Void will be created at the mid-point of the selected layers.

# New Variant

Click to create a shape layer alternative to a Adjustment layer. This is a comp-size, filled shape layer, with it's switch set to Adjustment layer. Why would this need to exist in the project folder?

# New Volume

Click to create a shape layer alternative to a Solid layer. This is a comp-size, filled shape layer. A color picker will open at creation, but you may just as easily press ESC on your keyboard to dismiss it.

Solids do still have a use

Keep in mind that some effects need absolute coordinates to draw correctly. If you use a shape layer (like a Volume), it will not be possible to transform the effect by transforming the layer. Create a Volume from the dockable ScriptUI panel, and hold the ALT/Option key to automatically precomp the new Volume layer.

But at this point you are creating a new precomp in the project instead of a solid layer. And you might just want to keep using a Solid. Pick your poison.

# Replace

Legacy layers may be replaced in a comp or the entire project by clicking any of these buttons.

After replacing, Void will check the Project panel to see if the source layers are used in any other comps, and if not, will delete them. Enjoy a lighter project.


# Included files

β”œβ”€β”€ πŸ“‚ Void.zip
β”‚   β”œβ”€β”€ πŸ“‚ headless
β”‚   β”‚   β”‚   └── Void-newVariant.jsx
β”‚   β”‚   β”‚   └── Void-newVoid.jsx
β”‚   β”‚   β”‚   └── Void-newVolume.jsx
β”‚   β”œβ”€β”€ πŸ“‚ icon
β”‚   β”‚   β”‚   └── Void.svg
β”‚   β”œβ”€β”€ πŸ“‚ KBar
β”‚   β”‚   β”‚   └── Void.kbar
β”‚   β”‚   β”‚   └── download KBar.url
β”‚   β”œβ”€β”€ Void manual.url (link to this page)
β”‚   β”œβ”€β”€ Void.jsx

# Keyboard shortcut setup

Did you know that anything that exists as an Ae menu item may be set to a keyboard shortcut? Included with the download are 3 headless files that are used for creating the new layers.

Void controls
  • File > Scripts > Install Script
  • Select the included Headless script files
    • The files will be copied to Ae's scripts folder (one up from ScriptUI Panels)
    • OSX: /Applications/After Effects #version#/Scripts/
    • Windows: /Program Files/Adobe/Adobe After Effects #version#/Support Files/Scripts/
  • Restart After Effects
    • This will update the menu items
  • Open the Ae Keyboard Shortcuts: Edit > Keyboard Shortcuts
  • Search for Void
  • Update the keyboard shortcut to replace the native functions, or create your own

Dockable panel

CC2019+

Ae script install

In newer versions of After Effects, it is possible to install Void and other scripts without digging through your hard drive.

File > Scripts > Install Script UI Panel…

Restart Ae and Void will be available in the Window menu at the top of the screen. Scroll down to find the installed scripts.

CC2018 and older

RubberHose install
  • Unzip the Void.zip download
  • Copy Void.jsx (or .jsxbin) to the ScriptUI Panels folder
  • Restart After Effects
  • Void will be available in the Window menu at the top of the screen. Scroll down to find the installed scripts.

Install paths

  • OSX: /Applications/After Effects #version#/Scripts/ScriptUI Panels/
  • Windows: /Program Files/Adobe/Adobe After Effects #version#/Support Files/Scripts/ScriptUI Panels/

KBar install

Beginning in KBar 3, it is now possible to import new buttons.

Kbar install
  • Unzip the Void.zip download
  • Locate the included Void.kbar file
  • Inside of Ae, open KBar. Right click within the KBar panel > KBar settings
  • Navigate to the Settingstab
  • Click Import from .kbar
  • Navigate to Void.kbar
  • Feel free to move and rearrange buttons to best fit your layout


# Changelog

# 1.0.2

Released: 2022-12-28

# Added

  • Support for zeroing 3D layers
  • Support for finding the midpoint of 3D layers

# 1.0.1

Released: 2022-12-28

# Fixed

  • Replace solids was removing footage

# 1.0.0

Released: 2022-12-27

  • Initial release